Back End Prerequisites

.NET Framework 4.6

The Microsoft .Net Framework 4.6 must be installed. This is required in order to support SQL Server 2017.

Database Requirements

Before installation, ensure that you have either a Data Warehouse or a Staging database. Data Governor will create a DGStg schema in this database and use it to store Reconciliation datasets and results.

Note: This database is not managed by Data Governor; please ensure it is sized and backed up appropriately in accordance with your standard practice for a Data Warehouse.

Data Governor Service Account

The Service Account must be an Active Directory account.

Note: For Kepion integration, the Data Governor Service Account must have the same Admin rights as the Kepion Service Account on SQL Server and SSAS Server.

It is important the Data Governor Service Account needs to be setup as Server Administrator role on the SSAS server whereas the Kepion Service Account is automatically added during Kepion setup.

The Data Governor Service Account will be given the user name DataGovernorProxy in the DataGovernor and msdb databases.

The DataGovernorProxy will also be added to the Operating System & SSIS subsystems under SQL Server Agent Proxies.

In addition the Data Governor Service Account will need to be:

  • Member of the db_datareader role in the Target database and Source database, when using Data Migration.

  • Member of the ddl_admin role in the Target database, when using Data Migration.

For example, if you are exporting data from Server1.AdventureWorks to Server2.AdventureWorksDW, the service account must be a member of db_datareader for both SQL Server databases and also ddl_admin for Server2.AdventureWorksDW.

SQL Server Installation

As a minimum, the SQL Server 2012 Database Engine must be installed. Ensure that the SQL Server installation has been updated with the latest Service Packs.

Ensure that the following services are enabled:

  • SQL Server

  • SQL Server Integration Services (if using SSIS)

  • SQL Server Agent

Windows Installer 4.5

As a minimum, Windows Installer 4.5 must be installed.

Systems Administrator Permissions for Person Executing Installation Package (MSI).

Ensure the account used to execute the installation MSI has system administration rights on the server.

Relevant OLDEB and ODBC Drivers for Data Source

Ensure that OLEDB and ODBC drivers required for your data Sources have been installed.

If you have an Oracle Source, you may choose to use the Microsoft Oracle Connector by Attunity or the Oracle Data Provider for .NET (ODP.NET).

Version Upgrades for Data Governor

Going from Version 5.0 to Version 5.2

If you are upgrading from Data Governor V5.0 to V5.2, you will need to reactivate Data Governor using the activation code previously supplied. For steps on how to activate your licence, refer to the Data Governor 5.2 User Guide.

Going from Version 4.x to Version 5.2

If you are upgrading from Data Governor V4.x to V5.2, you will need to install Data Governor V5.0 prior to installing V5.2.

Important Note

If you are upgrading from an earlier version of Data Governor, prior to reinstalling the newer version you will need to ensure that:

1.  You have a backup of the DataGovernorData database before running the installer.

2.  That all of your existing connections names, file definition names, process names, job names, and user id names are unique. The installation will fail if there are duplicate names.

You will need to rename or delete items in the UI to ensure there are no duplicates before the upgrade can be completed.