Web Interface Prerequisites

NET Framework 4.5

The Microsoft .Net Framework 4.5 must be installed.

Windows Installer 4.5

As a minimum, Windows Installer 4.5 must be installed.

Web Server IIS Role in Server Manager

When the Data Governor Web Interface installer is executed, the installation package (MSI) will attempt to create a Data Governor web site. As such, an IIS service must already be enabled and configured correctly on the server before the installation begins.

To enable IIS and configure IIS services on the server, ensure to carry out the following steps:

Go to the Start Menu -> Administrative Tools. Click on Server Manager.

Click on Roles and see if the Web Server (IIS) role is already installed.

If the Web Server (IIS) role is not already installed, add the role.

After the role is enabled, click on the Web Server (IIS) role and scroll down to the Role Services section.

Ensure that the installed services is consistent with the installed services in the following list:

1

Tip: When installing the Data Governor UI on the same server as the database, ensure that the IIS Application Pool default for ‘Enable 32-bit Applications’ is False or set the value to False after installation. This will ensure the UI uses the same set of 64-bit ODBC and OLEDB drivers as the back end.

Browser Compatibility

Data Governor V5.2 is now supported in Internet Explorer (IE) 9, 10, 11 & Edge.

Data Governor V5.2 also works on Firefox, V32 (April 29, 2014) and onwards. Chrome, V29 (2013-08-20).

If you are using Internet Explorer, make sure you have the “Display intranet sites in Compatibility View” unchecked.

1.  Within the IE browser go to Tools> Compatibility View settings.

2.  Make sure you have the first checkbox un-ticked.

3.  Close.

2